CVE-2026-23076: Linux kernel · ALSA: ctxfi: Fix potential OOB access in audio mixer handling
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.1 Medium · fixed in 5.15.0-1105.112~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1105.112~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1114.123~20.04.1 +71
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released by Ubuntu in updated Linux kernel packages for affected versions. Users should apply the official security updates provided by their Linux distribution, specifically upgrading to the fixed kernel versions listed in the Ubuntu advisories USN-8162-1 and USN-8180-1. After updating, a system reboot is required to apply the fixes. Due to ABI changes, third-party kernel modules must be recompiled and reinstalled. No additional mitigation steps are required beyond applying the official patches and rebooting.
Description
A vulnerability in the Linux kernel's ALSA ctxfi audio mixer handling was fixed to address a potential out-of-bounds (OOB) access caused by improper initialization of loop indices. This flaw could lead to memory corruption and denial of service. The issue was identified by fuzzing tools and corrected by adding proper initialization in the affected code. The vulnerability has a CVSS score of 7.1, indicating a medium severity level. Multiple Linux kernel versions prior to specific 5.15.x releases are affected. Official patches are available and distributed through Ubuntu security updates, requiring system updates and reboots to apply. Users should update to the fixed kernel versions to mitigate this issue.
References
- ubuntu.com/security/CVE-2026-23076 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-23076 (opens in a new tab)
- git.kernel.org/linus/61006c540cbdedea83b05577dc7fb7fa18fe1276 (opens in a new tab)
- git.kernel.org/stable/c/61006c540cbdedea83b05577dc7fb7fa18fe1276 (opens in a new tab)
- git.kernel.org/stable/c/873e2360d247eeee642878fcc3398babff7e387c (opens in a new tab)
- git.kernel.org/stable/c/a8c42d11b0526a89192bd2f79facb4c60c8a1f38 (opens in a new tab)
- git.kernel.org/stable/c/d77ba72558cd66704f0fb7e0969f697e87c0f71c (opens in a new tab)
- ubuntu.com/security/notices/USN-8162-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8180-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8180-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8186-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8187-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8188-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8180-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8180-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8180-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8243-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8180-6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8275-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8278-1 (opens in a new tab)