Skip to main content
VulnerabilityPublished Updated

CVE-2026-23092: Linux kernel · iio: dac: ad3552r-hs: fix out-of-bound write in ad3552r_hs_write_data_source

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 6.17.0-1021.21~24.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1021.21~24.04.1, 6.17.0-1021.24~24.04.1, 6.17.0-41.41~24.04.1 +4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • 6.14.0-15.15 – 6.17.0-40.40
20 affected builds
Fixed in–
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1019.19
17 affected builds
Fixed in–
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1006.6 – 6.17.0-1020.22
17 affected builds
Fixed in–
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1018.18
16 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The vendor advisory from Ubuntu confirms that updating to Linux kernel versions 6.17.0-1021.21~24.04.1 or later resolves this issue. After applying the update, a system reboot is required. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. Users should follow the vendor's update instructions to ensure full remediation.

Description

A vulnerability in the Linux kernel's iio: dac: ad3552r-hs driver caused an out-of-bounds write due to improper handling of buffer size and null termination. The issue occurs when simple_write_to_buffer() returns fewer bytes than requested, but the code incorrectly uses the original count for null termination, potentially writing beyond the stack buffer. This flaw has been fixed in Linux kernel versions 6.17.0-1021.21~24.04.1 and later. The vulnerability has a CVSS score of 7.8, indicating high severity, and a patch is available. Users should update their Linux kernel to the fixed versions to mitigate this issue.

Reports on CVE-2026-23092

References

Community reviews

Loading reviews…