Skip to main content
VulnerabilityPublished Updated

CVE-2026-23180: Linux kernel · dpaa2-switch: add bounds check for if_id in IRQ handler

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-23180· High 7.0

Not known to be exploited · CVSS 7.0 High · fixed in 5.15.0-1111.118~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1111.118~20.04.1, 5.15.0-1116.125~20.04.1, 5.15.0-1111.121~20.04.1 +62
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • 6.14.0-15.15 – 6.17.0-40.40
20 affected builds
Fixed in–
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1019.19
17 affected builds
Fixed in–
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1006.6 – 6.17.0-1020.22
17 affected builds
Fixed in–
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1018.18
16 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available from the vendor. Users should update their linux-hwe-edge kernel packages to versions 5.15.0-1111.118~20.04.1 or later, 5.15.0-1116.125~20.04.1 or later, 5.15.0-1111.121~20.04.1 or later, or 5.15.0-185.195~20.04.1 or later as applicable. After updating, a system reboot is required to apply the kernel fixes. No additional mitigations are specified by the vendor advisory.

Description

A vulnerability in the Linux kernel's dpaa2-switch IRQ handler allowed an out-of-bounds read due to missing bounds checking on the if_id index extracted from hardware status. This issue was resolved by adding proper validation before accessing the ports array. The vulnerability affects certain linux-hwe-edge kernel versions prior to specific 5.15.x releases. The flaw has a CVSS score of 7.0, indicating a medium severity with high impact on confidentiality, integrity, and availability. A patch is available and included in updated kernel packages. Users should update and reboot to apply the fix.

References

Community reviews

Loading reviews…