Skip to main content
VulnerabilityPublished Updated

CVE-2026-23262: Linux kernel · gve: Fix stats report corruption on queue count change

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1111.118~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1111.118~20.04.1, 5.15.0-1116.125~20.04.1, 5.15.0-1111.121~20.04.1 +58
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threatsAffected
  • 6.14.0-15.15 – 6.17.0-40.40
20 affected builds
Fixed in–
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1019.19
17 affected builds
Fixed in–
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1020.22?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1006.6 – 6.17.0-1020.22
17 affected builds
Fixed in–
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1018.18?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1018.18
16 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating the Linux kernel to versions 5.15.0-1111.118~20.04.1 or later as provided by the vendor. After updating, a system reboot is required to apply the changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Follow the vendor's official update instructions and use standard system update mechanisms to obtain the fix.

Description

A vulnerability in the Linux kernel's gve driver caused memory corruption due to improper handling of stats reporting when the queue count changes. The NIC could write beyond the allocated stats region if the queue count increased, or cause incorrect stats reporting if decreased. This issue has been fixed by allocating the stats region with maximum size and adjusting the NIC stats offset calculation. The vulnerability affects certain versions of the linux-hwe-edge kernel prior to specific fixed versions. A patch is available and should be applied via standard system updates, followed by a reboot. The update requires recompilation of third-party kernel modules due to an ABI change.

References

Community reviews

Loading reviews…