CVE-2026-23359: Linux kernel · bpf: Fix stack-out-of-bounds write in devmap
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · patch available : patch Linux kernel soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1020.22?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1018.18?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied to affected Linux kernel versions to resolve this vulnerability. The vendor advisory confirms that the issue has been fixed in Linux kernel version 5.15.0-186.196 and later. Users should update their systems to these fixed versions or later to mitigate the risk. No additional mitigation steps are indicated by the vendor advisory.
Description
A stack-out-of-bounds write vulnerability was found and fixed in the Linux kernel's BPF subsystem, specifically in the devmap get_upper_ifindexes() function. The function iterates over upper devices and writes their indices into a stack-allocated array without proper bounds checking, which can lead to memory corruption when the number of upper devices exceeds the assumed maximum (MAX_NEST_DEV). This issue affects Linux kernel versions prior to 5.15.0-186.196 and several specific older versions. The vulnerability is addressed by adding a maximum parameter to limit iteration and returning an error when too many upper devices are present, preventing the out-of-bounds write. The CVSS score is 7.8, indicating high impact on confidentiality, integrity, and availability. A patch is available as per the vendor advisory.
References
- ubuntu.com/security/CVE-2026-23359 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-23359 (opens in a new tab)
- git.kernel.org/linus/b7bf516c3ecd9a2aae2dc2635178ab87b734fef1 (opens in a new tab)
- git.kernel.org/stable/c/5000e40acc8d0c36ab709662e32120986ac22e7e (opens in a new tab)
- git.kernel.org/stable/c/75d474702b2ba8b6bcb26eb3004dbc5e95ffd5d2 (opens in a new tab)
- git.kernel.org/stable/c/8a95fb9df1105b1618872c2846a6c01e3ba20b45 (opens in a new tab)
- git.kernel.org/stable/c/b7bf516c3ecd9a2aae2dc2635178ab87b734fef1 (opens in a new tab)
- git.kernel.org/stable/c/ca831567908fd3f73cf97d8a6c09a5054697a182 (opens in a new tab)
- git.kernel.org/stable/c/d2c31d8e03d05edc16656e5ffe187f0d1da763d7 (opens in a new tab)
- ubuntu.com/security/notices/USN-8567-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8596-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8606-1 (opens in a new tab)