Skip to main content
VulnerabilityPublished Updated

CVE-2026-23407: Linux kernel · apparmor: fix missing bounds check on DEFAULT table in verify_dfa()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1156.166~18.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.0-1156.166~18.04.1, 5.4.0-1161.167~18.04.1, 5.4.0-1159.168~18.04.1 +92
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-19.19?arch=source&distro=questingOther threatsAffected
  • <6.17.0-19.19
Fixed in
  • 6.17.0-19.19
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1010.10?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1009.9?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.9
Fixed in
  • 6.17.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions to remediate this vulnerability. The vendor advisory from Ubuntu confirms that fixes have been released. Users should update their systems to the patched kernel versions as soon as possible to mitigate the risk.

Description

A vulnerability in the Linux kernel's AppArmor security module was fixed, addressing a missing bounds check in the verify_dfa() function. This flaw allowed out-of-bounds reads and writes when processing malformed DFA data, potentially leading to kernel memory corruption. The issue affects specific Linux kernel versions and has been assigned CVE-2026-23407 with a CVSS score of 7.8. A patch is available to correct this vulnerability.

References

Community reviews

Loading reviews…