CVE-2026-23448: Linux kernel · net: usb: cdc_ncm: add ndpoffset to NDP16 nframes bounds check
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · patch available : patch Linux kernel soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1020.22?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1018.18?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released by the Linux kernel maintainers and Ubuntu security team. Users should update their Linux kernel to version 6.8.0-1061.64~22.04.1 or later (or the corresponding patched versions) and reboot the system to apply the fix. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigation steps are required beyond applying the official patch.
Description
In the Linux kernel, the following vulnerability has been resolved: net: usb: cdc_ncm: add ndpoffset to NDP16 nframes bounds check cdc_ncm_rx_verify_ndp16() validates that the NDP header and its DPE entries fit within the skb. The first check correctly accounts for ndpoffset: if ((ndpoffset + sizeof(struct usb_cdc_ncm_ndp16)) > skb_in->len) but the second check omits it: if ((sizeof(struct usb_cdc_ncm_ndp16) + ret * (sizeof(struct usb_cdc_ncm_dpe16))) > skb_in->len) This validates the DPE array size against the total skb length as if the NDP were at offset 0, rather than at ndpoffset. When the NDP is placed near the end of the NTB (large wNdpIndex), the DPE entries can extend past the skb data buffer even though the check passes. cdc_ncm_rx_fixup() then reads out-of-bounds memory when iterating the DPE array. Add ndpoffset to the nframes bounds check and use struct_size_t() to express the NDP-plus-DPE-array size more clearly.
References
- ubuntu.com/security/CVE-2026-23448 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-23448 (opens in a new tab)
- git.kernel.org/linus/2aa8a4fa8d5b7d0e1ebcec100e1a4d80a1f4b21a (opens in a new tab)
- git.kernel.org/stable/c/2aa8a4fa8d5b7d0e1ebcec100e1a4d80a1f4b21a (opens in a new tab)
- git.kernel.org/stable/c/403f94ddcb36c552fbef51dea735b131e3dcde8b (opens in a new tab)
- git.kernel.org/stable/c/789204f980730258c983102c027c375238009c80 (opens in a new tab)
- git.kernel.org/stable/c/dce9dda0e3707e887977db44407989e9ead26611 (opens in a new tab)
- git.kernel.org/stable/c/f1c7701d3ac91b62d672c13690cf295821f0d5c3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8567-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8596-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8606-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8607-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8608-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8609-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-3 (opens in a new tab)