CVE-2026-23918: Apache HTTP Server · Double Free
Affects Apache HTTP ServerSource CVE Database V5
Public exploit available (Exploit-DB) · 49% EPSS · CVSS 8.8 High · fixed in 2.4.67 : patch Apache HTTP Server as a priority.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 49.7% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.67
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by Apache Software Foundation
, 105 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 22 minutes after disclosure
First Exploit-DB entry (opens in a new tab)
Apache HTTP Server 2.4.66 - 'mod_http2' Double-Free Denial of Service
, 22 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
Apacheapache/httpdpkg:rpm/apache/httpdOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Apache HTTP Server version 2.4.67. Users should upgrade from version 2.4.66 to 2.4.67 or later to remediate this vulnerability. Red Hat has released updated RPM packages for their Hardened Images that include this fix. Applying these updates as per vendor instructions will mitigate the risk. Patch status is confirmed by vendor advisories.
Description
Double Free and possible RCE vulnerability in Apache HTTP Server with the HTTP/2 protocol. This issue affects Apache HTTP Server: 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
References
- httpd.apache.org/security/vulnerabilities_24.html (opens in a new tab)
- openwall.com/lists/oss-security/2026/05/04/19 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-23918 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2465304 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-23918.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:13938 (opens in a new tab)