Skip to main content
VulnerabilityPublished

CVE-2026-24222: NVIDIA NemoClaw · Exposure of Sensitive System Information to an Unauthorized Control Sphere

Affects NVIDIA NemoClawSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 0.0.18 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.0.18
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NVIDIA NemoClaw to 0.0.18.

Affected software

ProductAffectedFixed in
NVIDIANemoClawAffected
  • =All versions prior to v0.0.18
Fixed in–
npmnemoclawpkg:npm/nemoclawOther threatsAffected
  • <0.0.18
Fixed in
  • 0.0.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider restricting network access to the vulnerable component and monitor for suspicious activity related to prompt injection. Avoid deploying affected versions in untrusted environments where remote attackers could interact with the sandbox initialization process.

Description

NVIDIA NeMoClaw has a vulnerability in its sandbox environment initialization component that allows a remote attacker to cause improper access control. By sending prompt-injected content, the attacker can cause the agent to read and exfiltrate host environment variables that are not properly restricted during sandbox creation. This vulnerability can lead to the disclosure of sensitive system information. It affects all versions prior to v0.0.18. The vulnerability has a high severity with a CVSS score of 8.6. There is no confirmed patch or official remediation available at this time.

References

Community reviews

Loading reviews…