CVE-2026-24754: kiteworks security-advisories · Cross-site Scripting
Affects kiteworks security-advisoriesSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 9.3.0 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade security-advisories and kiteworks/security-advisories to 9.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| kiteworkssecurity-advisories | Affected
| Fixed in
|
GitHubkiteworks/security-advisoriespkg:github/kiteworks/security-advisoriesOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Kiteworks Secure Data Forms to version 9.3.0 or later to apply the official patch addressing this stored XSS vulnerability. No other mitigation details are provided, and no temporary fixes are noted. Patch status is confirmed by the vendor advisory indicating the fix in version 9.3.0.
Description
Kiteworks Secure Data Forms versions prior to 9.3.0 contain a stored cross-site scripting (XSS) vulnerability. This flaw allows an authenticated attacker to inject and execute arbitrary JavaScript code in other users' sessions. The vulnerability is fixed in version 9.3.0 and later.