Skip to main content
VulnerabilityPublished Updated

CVE-2026-24983: UpSolution Core (WordPress plugin) · Cross-site Scripting

Affects UpSolution Core (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 8.42 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.42
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade UpSolution Core (WordPress plugin) to 8.42.

Affected software

ProductAffectedFixed in
UpSolutionUpSolution CoreAffected
  • <8.42
Fixed in
  • 8.42

AI-suggested

If you cannot patch yet, users should exercise caution with untrusted input and consider implementing web application firewall (WAF) rules or input validation as temporary mitigations.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in UpSolution UpSolution Core us-core allows Reflected XSS.This issue affects UpSolution Core: from n/a through <= 8.41.

References

Community reviews

Loading reviews…