Skip to main content
VulnerabilityPublished Updated

CVE-2026-25025: VikRestaurants (WordPress plugin) · Cross-site Scripting

Affects VikRestaurants (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 1.5.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade VikRestaurants (WordPress plugin) to 1.5.3.

Affected software

ProductAffectedFixed in
e4jvikwpVikRestaurantsAffected
  • <1.5.3
Fixed in
  • 1.5.3

AI-suggested

If you cannot patch yet, users should consider applying input validation and output encoding as temporary mitigations to reduce the risk of reflected XSS. Monitoring for suspicious input and user reports of unexpected behavior may also help detect exploitation attempts.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in e4jvikwp VikRestaurants vikrestaurants allows Reflected XSS.This issue affects VikRestaurants: from n/a through <= 1.5.2.

References

Community reviews

Loading reviews…