CVE-2026-25125: octobercms october · Information Exposure
Affects octobercms octoberSource CVE Database V5
Not known to be exploited · CVSS 4.9 Medium : upgrade to 4.1.10 or 3.7.14 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.10, 3.7.14
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade october to 4.1.10 or 3.7.14; octobercms/october to 3.7.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| octobercmsoctober | Affected
| Fixed in
|
| octobercmsoctober | Affected
| Fixed in
|
GitHuboctobercms/octoberpkg:github/octobercms/octoberOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in OctoberCMS versions 3.7.14 and 4.1.10; users should upgrade to these or later versions. For those unable to upgrade immediately, restrict Editor tool access to fully trusted administrators only and ensure that database and cloud service credentials are not accessible from the web server's network. Since this is a cloud-hosted service, the vendor manages remediation for the cloud environment; users should verify with the vendor advisory for cloud-specific patching status.
Description
OctoberCMS versions prior to 3.7.14 and 4.1.10 have a server-side information disclosure vulnerability in the INI settings parser. Attackers with Editor access can inject environment variable interpolation patterns into CMS page settings, causing sensitive environment variables such as database passwords and application keys to be exposed. This vulnerability is relevant only when cms.safe_mode is enabled. It has been fixed in versions 3.7.