CVE-2026-25133: octobercms october · Cross-site Scripting
Affects octobercms octoberSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 4.1.10 or 3.7.14 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.10, 3.7.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade october to 4.1.10 or 3.7.14; octobercms/october to 3.7.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| octobercmsoctober | Affected
| Fixed in
|
| octobercmsoctober | Affected
| Fixed in
|
GitHuboctobercms/octoberpkg:github/octobercms/octoberOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been fixed in OctoberCMS versions 3.7.14 and 4.1.10. Users should upgrade to these or later versions to remediate the issue. Since the vulnerability requires authenticated backend access with media upload permissions, limiting such access can reduce risk until patching is applied. Patch status is not explicitly stated as 'official-fix' in the vendor advisory, but the fixed versions indicate an official remediation is available.
Description
October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a stored cross-site scripting (XSS) vulnerability in the SVG sanitization logic. The regex pattern used to strip event handler attributes (such as onclick or onload) could be bypassed using a crafted payload that exploits how the pattern matches attribute boundaries, allowing malicious SVG files to be uploaded through the Media Manager with embedded JavaScript. Exploitation could lead to privilege escalation if a superuser views or embeds the malicious SVG, and requires authenticated backend access with media upload permissions. The SVG must be viewed or embedded in a page for the payload to trigger. This issue has been fixed in versions 3.7.14 and 4.1.10.