Skip to main content
VulnerabilityPublished Updated

CVE-2026-25360: Vex (WordPress plugin) · Deserialization of Untrusted Data

Affects Vex (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 1.2.9 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Vex (WordPress plugin) to 1.2.9.

Affected software

ProductAffectedFixed in
rascalsVexAffected
  • <1.2.9
Fixed in
  • 1.2.9

AI-suggested

If you cannot patch yet, avoid processing untrusted serialized data with vulnerable versions of rascals Vex.

Description

Deserialization of Untrusted Data vulnerability in rascals Vex vex allows Object Injection.This issue affects Vex: from n/a through < 1.2.9.

References

Community reviews

Loading reviews…