CVE-2026-25447: Widget Wrangler (WordPress plugin) · Code Injection
Affects Widget Wrangler (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.4.0 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Widget Wrangler (WordPress plugin) to 2.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Jonathan DaggerhartWidget Wrangler | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the Widget Wrangler plugin to trusted users only and monitor for suspicious activity related to code injection attempts.
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Jonathan Daggerhart Widget Wrangler widget-wrangler allows Code Injection.This issue affects Widget Wrangler: from n/a through <= 2.3.9.