CVE-2026-25484: craftcms commerce · Cross-site Scripting
Affects craftcms commerceSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 5.5.2 or 4.10.1 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.5.2, 4.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade commerce to 5.5.2 or 4.10.1; craftcms/commerce to 5.5.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscommerce | Affected
| Fixed in
|
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade Craft Commerce installations to versions 4.10.1 or 5.5.2 or later to apply the official patch that sanitizes product type names. Until patching is complete, restrict permissions to create or modify product types to the smallest necessary group of trusted administrators. Implement Content Security Policy (CSP) headers to limit the impact of any injected scripts by restricting script sources and execution contexts. Conduct regular audits of product type names and user permissions pages for suspicious or unexpected input. Employ web application firewalls (WAFs) with rules targeting common XSS payloads to provide an additional layer of defense. Educate administrators about the risks of clicking on untrusted links or loading unknown pages within the CMS environment. Monitor logs for unusual activity related to product type modifications or user permissions access. Finally, integrate vulnerability scanning and penetration testing focused on CMS components to detect similar issues proactively.
Description
CVE-2026-25484 is a stored cross-site scripting (XSS) vulnerability in Craft Commerce versions 4.0.0-RC1 to 4.10.0 and 5.0.0 to 5.5.1. The vulnerability arises because product type names are not properly sanitized when displayed in the CMS user permissions settings, allowing malicious scripts to be stored and executed.
References
- github.com/craftcms/commerce/security/advisories/GHSA-2h2m-v2mg-656c (opens in a new tab)
- github.com/craftcms/commerce/commit/7e1dedf06038c8e70dce0187b7048d4ab8ffb75c (opens in a new tab)
- github.com/craftcms/commerce/releases/tag/4.10.1 (opens in a new tab)
- github.com/craftcms/commerce/releases/tag/5.5.2 (opens in a new tab)