Skip to main content
VulnerabilityPublished

CVE-2026-25699: Apache Answer · Exposure of Private Personal Information to an Unauthorized Actor

Affects Apache AnswerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium · fixed in 2.0.1 : update Apache Answer when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AnswerAffected
  • <=2.0.0
Fixed in–
Mavenorg.apache.answer/answerpkg:maven/org.apache.answer/answerOther threatsAffected
  • <=2.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Answer to version 2.0.1 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated. Patch status is confirmed by the vendor's recommendation to upgrade.

Description

Apache Answer versions up to and including 2.0.0 contain a vulnerability where timeline-related APIs do not enforce proper authorization checks. This flaw allows authenticated users to access deleted, private, or unapproved content and its revision history. The issue is fixed in version 2.0.1. The vulnerability has a medium severity with a CVSS score of 6.1.

References

Community reviews

Loading reviews…