Skip to main content
VulnerabilityPublished

CVE-2026-25705: SUSE rancher · Path traversal: '.../...//

Affects SUSE rancherSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High · fixed in 2.14.1 : patch SUSE rancher soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.1, 2.13.5, 2.12.9 +1
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade rancher and github.com/rancher/rancher to 2.14.1, 2.13.5, 2.12.9 or 2.11.13.

Affected software

ProductAffectedFixed in
SUSErancherAffected
  • >=2.14.0 <2.14.1
Fixed in
  • 2.14.1
SUSErancherAffected
  • >=2.13.0 <2.13.5
Fixed in
  • 2.13.5
SUSErancherAffected
  • >=2.12.0 <2.12.9
Fixed in
  • 2.12.9
SUSErancherAffected
  • >=2.10.11 <2.11.13
Fixed in
  • 2.11.13
GitHubrancher/rancherpkg:github/rancher/rancherOther threatsAffected
  • 2.10.11 – 2.14.0
4 affected builds
Fixed in–
GitHubgithub.com/rancher/rancherpkg:github/github.com/rancher/rancherOther threatsAffected
  • >=2.14.0 <2.14.1
  • >=2.13.0 <2.13.5
  • >=2.12.0 <2.12.9
  • >=2.10.11 <2.11.13
Fixed in
  • 2.14.1
  • 2.13.5
  • 2.12.9
  • 2.11.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict deployment of untrusted UI extensions and avoid mounting hostPath volumes in UIPlugin deployments to reduce risk.

Description

CVE-2026-25705 is a high-severity path traversal vulnerability in SUSE Rancher's Extensions component. It allows a malicious UI extension to inject code by exploiting the compressedEndpoint field in a UIPlugin deployment. Successful exploitation can lead to overwriting Rancher binaries or configurations, tampering with cluster state, writing to the host filesystem if hostPath volumes are mounted, and chaining with other attack vectors. The vulnerability affects Rancher versions 2.10.11, 2.12.0, 2.13.0, and 2.

References

Community reviews

Loading reviews…