CVE-2026-25817: Code Injection
Source CVE Database V5
Not known to be exploited · CVSS 8.8 High.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
Organizations should immediately verify the firmware versions of their HMS Networks Ewon Flexy and Cosy+ devices and upgrade to firmware versions 15.0s4 or later for Flexy, 22.1s6 or later for Cosy+ 22.xx, and 23.0s3 or later for Cosy+ 23.xx. If immediate patching is not possible, restrict network access to these devices to trusted management networks only and enforce strong authentication policies, including multi-factor authentication where supported. Regularly audit and rotate credentials to reduce the risk of credential compromise. Implement network segmentation to isolate these gateways from critical systems and monitor device logs for unusual command execution or access patterns. Additionally, consider deploying intrusion detection systems capable of identifying command injection attempts targeting these devices. Vendors and users should collaborate to ensure timely updates and share threat intelligence regarding any emerging exploits.
Description
CVE-2026-25817 is a high-severity vulnerability affecting HMS Networks Ewon Flexy and Cosy+ devices with certain firmware versions. The flaw arises from improper neutralization of special elements in OS commands, enabling remote code execution by attackers who have low privilege access and valid credentials on the gateway. Exploitation does not require user interaction but does require authentication. The vulnerability impacts confidentiality, integrity, and availability, allowing attackers to execute arbitrary commands remotely. No known exploits are currently reported in the wild. The vulnerability is tracked under CWE-94 (Improper Control of Generation of Code).