Skip to main content
VulnerabilityPublished Updated

CVE-2026-25917: Apache Airflow · Deserialization of Untrusted Data

Affects Apache AirflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 3.2.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow and apache-airflow to 3.2.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • <3.2.0
Fixed in
  • 3.2.0
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • <3.2.0
Fixed in
  • 3.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache Airflow version 3.2.0, which addresses this vulnerability. No other official remediation or temporary fixes are indicated. Patch status is not explicitly confirmed beyond the upgrade recommendation, so users should verify with the vendor advisory for the latest guidance.

Description

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

References

Community reviews

Loading reviews…