Skip to main content
VulnerabilityPublished Updated

CVE-2026-26332: patriksimek vm2 · Code Injection

Affects patriksimek vm2Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.11.0 as a priority.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.11.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade patriksimek vm2 to 3.11.0.

Affected software

ProductAffectedFixed in
patriksimekvm2Affected
  • <3.11.0
Fixed in
  • 3.11.0
npmvm2pkg:npm/vm2Other threatsAffected
  • <3.11.0
Fixed in
  • 3.11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade vm2 to version 3.11.0 or later, where this vulnerability has been patched. The vendor advisory confirms the fix is available upstream. No additional mitigations are indicated by the vendor advisory.

Description

vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.0, SuppressedError allows attackers to escape the sandbox and run arbitrary code. This issue has been patched in version 3.11.0.

References

Community reviews

Loading reviews…