Skip to main content
VulnerabilityPublished

CVE-2026-2652: mlflow/mlflow · Authentication Bypass by Primary Weakness

Affects mlflow/mlflowSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · 20% EPSS · CVSS 8.6 High : upgrade to 3.10.0 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
20.7% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.10.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 May 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mlflow to 3.10.0.

Affected software

ProductAffectedFixed in
mlflowmlflow/mlflowAffected
  • ≥ unspecified, < 3.10.0
Fixed in–
PyPImlflowpkg:pypi/mlflowOther threatsAffected
  • <3.10.0
Fixed in
  • 3.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in mlflow version 3.10.0. Users should upgrade to version 3.10.0 or later to remediate this issue. Until upgraded, restrict access to the affected API endpoints through network controls or disable the affected routes if possible.

Description

A vulnerability in mlflow/mlflow versions 3.9.0 and earlier allows unauthenticated access to certain FastAPI routes when the server is started with authentication enabled (`--app-name basic-auth`) and served via uvicorn (ASGI). The FastAPI permission middleware only enforces authentication on `/gateway/` routes, leaving other routes such as the Job API (`/ajax-api/3.0/jobs/*`) and the OpenTelemetry trace ingestion API (`/v1/traces`) unprotected. This allows unauthenticated remote attackers to submit jobs, read job results, cancel running jobs, and inject arbitrary trace data into experiments. The issue arises from an architectural mismatch between Flask and FastAPI authentication mechanisms, where the `_find_fastapi_validator()` function fails to handle non-`/gateway/` paths, resulting in a complete authentication bypass. This vulnerability is fixed in version 3.10.0.

References

Community reviews

Loading reviews…