Skip to main content
VulnerabilityPublished Updated

CVE-2026-26951: Dell PowerProtect Data Domain · Stack-based Buffer Overflow

Affects Dell PowerProtect Data DomainSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.7 Medium · fixed in 8.6.1.10 : update Dell PowerProtect Data Domain when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.6.1.10, 8.3.1.30 or later, 7.13.1.70 or later +1
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Dell PowerProtect Data Domain to 8.6.1.10, 8.3.1.30 or later, 7.13.1.70 or later or 2.7.9 with DD OS 8.3.1.30.

Affected software

ProductAffectedFixed in
DellPowerProtect Data DomainAffected
  • =0
Fixed in
  • 8.6.1.10
  • 8.3.1.30 or later
  • 7.13.1.70 or later
  • 2.7.9 with DD OS 8.3.1.30

AI-suggested

If you cannot patch yet, restrict local access to trusted users only and monitor for suspicious activity. No official remediation or temporary fixes have been announced by Dell.

Description

Dell PowerProtect Data Domain, versions 7.7.1.0 through 8.6, LTS2025 release version 8.3.1.0 through 8.3.1.20, LTS2024 release versions 7.13.1.0 through 7.13.1.60 contain a stack-based buffer overflow vulnerability. A high privileged attacker with local access could potentially exploit this vulnerability, leading to arbitrary command execution with root privileges.

References

Community reviews

Loading reviews…