Skip to main content
VulnerabilityPublished Updated

CVE-2026-27144: Go toolchain cmd/compile · Expected Behavior Violation

Affects Go toolchain cmd/compileSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 1.26.2 or 1.25.9 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.26.2, 1.25.9
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Go toolchain cmd/compile to 1.26.2 or 1.25.9.

Affected software

ProductAffectedFixed in
Go toolchaincmd/compileAffected
  • >=1.26.0-0 <1.26.2
Fixed in
  • 1.26.2
Go toolchaincmd/compileAffected
  • <1.25.9
Fixed in
  • 1.25.9
Gocmd/compilepkg:golang/cmd/compileOther threatsAffected
  • <1.25.9
  • >=1.26.0-0 <1.26.2
Fixed in
  • 1.25.9
  • 1.26.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider avoiding affected versions or applying any available workarounds from the vendor.

Description

CVE-2026-27144 is a high-severity vulnerability in the Go toolchain's cmd/compile component. The issue arises because the compiler fails to correctly unwrap pointers during memory move operations due to a no-op interface conversion. This flaw can cause the compiler to incorrectly determine non-overlapping memory moves, potentially leading to memory corruption at runtime. The vulnerability affects Go versions up to 1.26.0-0. There is no vendor-provided patch or official remediation guidance available at this time, and no known exploits have been reported in the wild.

References

Community reviews

Loading reviews…