Skip to main content
VulnerabilityPublished Updated

CVE-2026-27172: Apache Camel · Deserialization of Untrusted Data

Affects Apache CamelSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.8 High : upgrade to 4.18.1 or 4.14.6 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 68% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.18.1, 4.14.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache to 4.18.1 or 4.14.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CamelAffected
  • >=4.15.0 <4.18.1
Fixed in
  • 4.18.1
Apache Software FoundationApache CamelAffected
  • >=3.0.0 <4.14.6
Fixed in
  • 4.14.6
MavenApache Software Foundation/org.apache.camel:camel-consulpkg:maven/Apache Software Foundation/org.apache.camel:camel-consulOther threatsAffected
  • >=3.0.0 <4.14.6
  • >=4.15.0 <4.18.1
Fixed in
  • 4.14.6
  • 4.18.1
Mavenorg.apache.camel/camel-corepkg:maven/org.apache.camel/camel-coreOther threatsAffected
  • =3.0.0
  • =4.15.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade to Apache Camel version 4.14.6 if using the 4.14.x LTS stream, to 4.18.1 if using the 4.18.x stream, or to 4.19.0 for newer versions. These versions include the necessary patch to prevent unsafe deserialization in the ConsulRegistry component. No alternative mitigations are specified in the vendor advisory; upgrading is the recommended remediation.

Description

The ConsulRegistry in the camel-consul component (class org.apache.camel.component.consul.ConsulRegistry and its inner ConsulRegistryUtils.deserialize method) read Java-serialized values from the Consul KV store and passed them to ObjectInputStream.readObject() without configuring an ObjectInputFilter. An attacker who can write to the Consul KV store backing a Camel ConsulRegistry instance could inject a malicious serialized Java object that is deserialized the next time Camel performs a lookup against that registry, leading to arbitrary code execution in the Camel process. The issue mirrors the class of vulnerability already addressed for other Camel components in CVE-2024-22369, CVE-2024-23114 and CVE-2026-25747, and was overlooked during the original remediation of those CVEs. This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.1. Users are recommended to upgrade to version 4.19.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.1.

References

Community reviews

Loading reviews…