CVE-2026-27421: Royal Elementor Addons (WordPress plugin) · Cross-site Scripting
Affects Royal Elementor Addons (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.7.1053 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.1053
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 7 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Royal Elementor Addons (WordPress plugin) to 1.7.1053.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WProyalRoyal Elementor Addons | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should exercise caution with input handling and consider applying any available temporary mitigations recommended by the vendor or security community. Monitoring for updates from WProyal is advised.
Description
CVE-2026-27421 is a stored cross-site scripting (XSS) vulnerability in the WProyal Royal Elementor Addons plugin. It arises from improper neutralization of input during web page generation, allowing malicious scripts to be stored and executed in users' browsers. The vulnerability affects versions before 1.7.1053. The CVSS 3.1 base score is 6.5, indicating a medium severity level. No known exploits in the wild have been reported.