Skip to main content
VulnerabilityPublished Updated

CVE-2026-27563: Pepperl+Fuchs ICE2-8IOL1-G65L-V1D · OS Command Injection

Affects Pepperl+Fuchs ICE2-8IOL1-G65L-V1DSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 1.7.4 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.7% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.4
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ICE2-8IOL1-G65L-V1D and ICE2-8IOL-G65L-V1D and ICE2-8IOL-K45P-RJ45 and ICE2-8IOL-K45S-RJ45 and ICE3-8IOL1-G65L-V1D and ICE3-8IOL-G65L-V1D and ICE3-8IOL-G65L-V1D-Y and ICE3-8IOL-K45P-RJ45 and ICE3-8IOL-K45S-RJ45 and IOL MA8 PN DI8 and IOL MA8 EIP DI8 and YL212CEI8M1IO and YN115CEI8RPIO and YL212CPN8M1IO and YN115CPN8RPIO to 1.7.4.

Affected software

ProductAffectedFixed in
Pepperl+FuchsICE2-8IOL1-G65L-V1DAffected
  • >=1.0.0 <1.7.4
Fixed in
  • 1.7.4
Pepperl+FuchsICE2-8IOL-G65L-V1DAffected
  • >=1.0.0 <1.7.4
Fixed in
  • 1.7.4
Pepperl+FuchsICE2-8IOL-K45P-RJ45Affected
  • >=1.0.0 <1.7.4
Fixed in
  • 1.7.4
Pepperl+FuchsICE2-8IOL-K45S-RJ45Affected
  • >=1.0.0 <1.7.4
Fixed in
  • 1.7.4
Pepperl+FuchsICE3-8IOL1-G65L-V1DAffected
  • >=1.0.0 <1.7.4
Fixed in
  • 1.7.4
Pepperl+FuchsICE3-8IOL-G65L-V1DAffected
  • >=1.0.0 <1.7.4
Fixed in
  • 1.7.4

AI-suggested

If you cannot patch yet, restrict access to the /api/datastorage/data endpoint to trusted administrators only and monitor for suspicious activity involving this endpoint. Ensure admin credentials are protected and rotated regularly.

Description

A high-privileged remote attacker can exploit a command injection vulnerability in the /api/datastorage/data endpoint by sending a crafted GET request with admin credentials allowing execution of commands with root privileges on the device.

References

Community reviews

Loading reviews…