Skip to main content
VulnerabilityPublished Updated

CVE-2026-27599: ci4-cms-erp ci4ms · Cross-site Scripting

Affects ci4-cms-erp ci4msSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.7 Medium : upgrade to 0.31.0.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.31.0.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.0.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <0.31.0.0
Fixed in
  • 0.31.0.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <0.31.0.0
Fixed in
  • 0.31.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ci4ms to version 0.31.0.0 or later, where this vulnerability has been patched. No additional mitigation is required if the system is updated. Patch status is confirmed by the vendor advisory indicating the fix in version 0.31.0.0.

Description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, the application fails to properly sanitize user-controlled input within System Settings – Mail Settings. Several configuration fields, including Mail Server, Mail Port, Email Address, Email Password, Mail Protocol, and TLS settings, accept attacker-controlled input that is stored server-side and later rendered without proper output encoding. This issue has been patched in version 0.31.0.0.

References

Community reviews

Loading reviews…