CVE-2026-27743: SPIP referer_spam · SQL Injection
Affects SPIP referer_spamSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.3.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade SPIP referer_spam to 1.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SPIPreferer_spam | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, it is recommended to restrict access to the vulnerable endpoints, implement web application firewall (WAF) rules to detect and block SQL injection attempts targeting the referer_spam_ajouter and referer_spam_supprimer handlers, and monitor for suspicious activity. Applying input validation and parameterization in custom deployments can mitigate risk. Avoid exposing these endpoints publicly if possible.
Description
The SPIP referer_spam plugin versions prior to 1.3.0 contain an unauthenticated SQL injection vulnerability in the referer_spam_ajouter and referer_spam_supprimer action handlers. The handlers read the url parameter from a GET request and interpolate it directly into SQL LIKE clauses without input validation or parameterization. The endpoints do not enforce authorization checks and do not use SPIP action protections such as securiser_action(), allowing remote attackers to execute arbitrary SQL queries.
References
- chocapikk.com/posts/2026/spip-plugins-vulnerabilities/ (opens in a new tab)
- blog.spip.net/Mise-a-jour-de-securite-sortie-de-SPIP-4-4-10.html (opens in a new tab)
- plugins.spip.net/referer_spam.html (opens in a new tab)
- git.spip.net/spip-contrib-extensions/referer_spam/-/commit/33682df73cd5f7e9c72d8c4d5088611fa2441683 (opens in a new tab)
- vulncheck.com/advisories/spip-referer-spam-unauthenticated-sql-injection (opens in a new tab)