CVE-2026-27794: langchain-ai langgraph-checkpoint · Deserialization of Untrusted Data
Affects langchain-ai langgraph-checkpointSource CVE Database V5
Not known to be exploited · CVSS 6.6 Medium : upgrade to 4.0.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade langchain-ai langgraph-checkpoint to 4.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| langchain-ailanggraph-checkpoint | Affected
| Fixed in
|
PyPIlanggraph-checkpointpkg:pypi/langgraph-checkpointOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade langgraph-checkpoint to version 4.0.0 or later, where this vulnerability is patched. If upgrading is not immediately possible, ensure that cache backends are not enabled or that cache storage is not writable by untrusted parties. Restrict write access to cache backends such as Redis instances and local cache files to trusted users and processes only. Patch status is confirmed fixed in version 4.0.0.
Description
A deserialization vulnerability (CWE-502) exists in langchain-ai's langgraph-checkpoint versions prior to 4.0.0. The issue arises when applications explicitly enable caching with cache backends inheriting from BaseCache and nodes opt into caching via CachePolicy. The default serializer falls back to pickle.loads for certain data, allowing remote code execution if an attacker can write malicious serialized data into the cache backend. Exploitation requires write access to the cache storage, making this a post-compromise escalation vector. The vulnerability is patched in langgraph-checkpoint version 4.0.0.
References
- github.com/langchain-ai/langgraph/security/advisories/GHSA-mhr3-j7m5-c7c9 (opens in a new tab)
- github.com/langchain-ai/langgraph/pull/6677 (opens in a new tab)
- github.com/langchain-ai/langgraph/commit/f91d79d0c86932ded6e3b9f195d5a0bbd5aef99c (opens in a new tab)
- github.com/langchain-ai/langgraph/releases/tag/checkpoint%3D%3D4.0.0 (opens in a new tab)