CVE-2026-27820: ruby zlib · Classic Buffer Overflow
Affects ruby zlibSource CVE Database V5
Not known to be exploited · CVSS 1.7 Low · fixed in 3.2.3 : update ruby zlib when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.3, 3.1.2, 3.0.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 16 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ruby zlib to 3.2.3, 3.1.2 or 3.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rubyzlib | Affected
| Fixed in
|
| rubyzlib | Affected
| Fixed in
|
| rubyzlib | Affected
| Fixed in
|
AI-suggested
Upgrade Ruby zlib to version 3.0.1, 3.1.2, or 3.2.3 or later, where this buffer overflow vulnerability has been fixed. Patch status is confirmed by the version fixes listed in the advisory. No additional mitigation is indicated.
Description
zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.