CVE-2026-27889: nats-server · Integer Overflow or Wraparound
Affects nats-serverSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.12.5 or 2.11.14 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.5, 2.11.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nats-server and nats-io/nats-server to 2.12.5 or 2.11.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nats-ionats-server | Affected
| Fixed in
|
| nats-ionats-server | Affected
| Fixed in
|
GitHubnats-io/nats-serverpkg:github/nats-io/nats-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in nats-server versions 2.11.14 and 2.12.5. Users are strongly advised to upgrade to these or later versions to remediate the vulnerability. If upgrading is not immediately possible, mitigating exposure by restricting access to the WebSockets port from untrusted endpoints or disabling WebSockets usage can reduce risk. Red Hat notes that no mitigation currently meets their criteria for ease of use and applicability, so patching is the recommended approach.
Description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Starting in version 2.2.0 and prior to versions 2.11.14 and 2.12.5, a missing sanity check on a WebSockets frame could trigger a server panic in the nats-server. This happens before authentication, and so is exposed to anyone who can connect to the websockets port. Versions 2.11.14 and 2.12.5 contains a fix. A workaround is available. The vulnerability only affects deployments which use WebSockets and which expose the network port to untrusted end-points. If one is able to do so, a defense in depth of restricting either of these will mitigate the attack.
References
- github.com/nats-io/nats-server/security/advisories/GHSA-pq2q-rcw4-3hr6 (opens in a new tab)
- advisories.nats.io/CVE/secnote-2026-03.txt (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-27889 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2451447 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-27889.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:22347 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:23345 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:21769 (opens in a new tab)