CVE-2026-27893: vllm · Protection Mechanism Failure
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 0.18.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade vllm and vllm-project/vllm to 0.18.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllm-projectvllm | Affected
| Fixed in
|
GitHubvllm-project/vllmpkg:github/vllm-project/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in vLLM version 0.18.0, which patches the hardcoded trust_remote_code=True setting. Users should upgrade to version 0.18.0 or later to remediate this vulnerability. Refer to the Red Hat advisories for additional details and updates. No other mitigations are indicated by the vendor advisory.
Description
vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.18.0, two model implementation files hardcode `trust_remote_code=True` when loading sub-components, bypassing the user's explicit `--trust-remote-code=False` security opt-out. This enables remote code execution via malicious model repositories even when the user has explicitly disabled remote code trust. Version 0.18.0 patches the issue.
References
- github.com/vllm-project/vllm/security/advisories/GHSA-7972-pg2x-xr59 (opens in a new tab)
- github.com/vllm-project/vllm/pull/36192 (opens in a new tab)
- github.com/vllm-project/vllm/commit/00bd08edeee5dd4d4c13277c0114a464011acf72 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-27893 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2452055 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-27893.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:19724 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:19725 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:8748 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:8746 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:8747 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:10140 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:10141 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:42644 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:24977 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37275 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:19712 (opens in a new tab)