Skip to main content
VulnerabilityPublished Updated

CVE-2026-28807: wisp · Path Traversal

Affects wispSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 2.2.1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.1, 161118c431047f7ef1ff7cabfcc38981877fdd93
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade wisp to 2.2.1; wisp to 161118c431047f7ef1ff7cabfcc38981877fdd93.

Affected software

ProductAffectedFixed in
gleam-wispwispAffected
  • >=2.1.1 <2.2.1
Fixed in
  • 2.2.1
gleam-wispwispAffected
  • ≥ 129dcb1fe10ab1e676145d91477535e1c90ab550, < 161118c431047f7ef1ff7cabfcc38981877fdd93
Fixed in
  • 161118c431047f7ef1ff7cabfcc38981877fdd93
GitHubgleam-wisp/wisppkg:github/gleam-wisp/wispOther threatsAffected
  • =2.1.1
Fixed in–
Hexwisppkg:hex/wispOther threatsAffected
  • >=2.1.1 <2.2.1
Fixed in
  • 2.2.1

CPE configurations (1)

  • cpe:2.3:a:gleam-wisp:wisp:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider implementing access controls or filtering at the web server or application gateway level to block suspicious path traversal patterns, especially percent-encoded sequences. Avoid exposing the vulnerable wisp.serve_static functionality to untrusted users if possible.

Description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in gleam-wisp wisp allows arbitrary file read via percent-encoded path traversal. The wisp.serve_static function is vulnerable to path traversal because sanitization runs before percent-decoding. The encoded sequence %2e%2e passes through string.replace unchanged, then uri.percent_decode converts it to .., which the OS resolves as directory traversal when the file is read. An unauthenticated attacker can read any file readable by the application process in a single HTTP request, including application source code, configuration files, secrets, and system files. This issue affects wisp: from 2.1.1 before 2.2.1.

References

Community reviews

Loading reviews…