CVE-2026-28960: Apple iOS and iPadOS · Improper Input Validation
Affects Apple iOS and iPadOSSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 18.7.10 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.7.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade iOS and iPadOS and apple/ios and apple/ipados to 18.7.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AppleiOS and iPadOS | Affected
| Fixed in
|
Appleapple/iospkg:deb/apple/iosOther threats | Affected
| Fixed in
|
Appleapple/ipadospkg:deb/apple/ipadosOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official fix by updating Apple iOS and iPadOS to version 18.7.10 or later. This update contains the improved validation that resolves the denial-of-service issue.
Description
CVE-2026-28960 is a denial-of-service vulnerability in Apple iOS and iPadOS that allows a remote attacker to cause a denial-of-service condition. The issue was addressed by improved validation and is fixed in iOS and iPadOS version 18.7.10.