Skip to main content
VulnerabilityPublished Updated

CVE-2026-29000: pac4j-jwt · Improper Verification of Cryptographic Signature

Affects pac4j-jwtSource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical · fixed in 6.3.3 : patch pac4j-jwt as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
6.0% chance of exploitation in 30 days – higher than 93% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.3.3, 5.7.9, 4.5.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pac4j-jwt to 6.3.3, 5.7.9 or 4.5.9.

Affected software

ProductAffectedFixed in
pac4jpac4j-jwtAffected
  • >=6.0 <6.3.3
Fixed in
  • 6.3.3
pac4jpac4j-jwtAffected
  • >=5.0 <5.7.9
Fixed in
  • 5.7.9
pac4jpac4j-jwtAffected
  • >=4.0 <4.5.9
Fixed in
  • 4.5.9
Mavenorg.pac4j/pac4j-jwtpkg:maven/org.pac4j/pac4j-jwtOther threatsAffected
  • =4.0
  • =5.0
  • =6.0
Fixed in–
GitHubpac4j-jwtpkg:github/pac4j-jwtOther threatsAffected
  • >=4.0 <4.5.9
  • >=5.0 <5.7.9
  • >=6.0 <6.3.3
Fixed in
  • 4.5.9
  • 5.7.9
  • 6.3.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the server's RSA public key and monitor for suspicious JWT usage. Avoid using affected versions and upgrade to versions 4.5.9, 5.7.9, or 6.3.3 or later once confirmed by the vendor.

Description

pac4j-jwt versions prior to 4.5.9, 5.7.9, and 6.3.3 contain an authentication bypass vulnerability in JwtAuthenticator when processing encrypted JWTs that allows remote attackers to forge authentication tokens. Attackers who possess the server's RSA public key can create a JWE-wrapped PlainJWT with arbitrary subject and role claims, bypassing signature verification to authenticate as any user including administrators.

References

Community reviews

Loading reviews…