Skip to main content
VulnerabilityPublished

CVE-2026-29129: Apache Tomcat · Configured Cipher Preference Order Not Preserved

Affects Apache TomcatSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 11.0.20 : patch Apache Tomcat soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.20
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache TomcatAffected
  • >=11.0.16 <=11.0.18
  • >=10.1.51 <=10.1.52
  • >=9.0.114 <=9.0.115
Fixed in–
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • 9.0.114 – 11.0.18
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat installations to versions 11.0.20, 10.1.53, or 9.0.116 where the vulnerability is fixed. Since this is a software vulnerability with an official fix available, applying the update is the recommended remediation. No other mitigation guidance is provided or necessary.

Description

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

References

Community reviews

Loading reviews…