CVE-2026-29145: Apache Tomcat · Improper Authentication
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 9.0.116 : patch Apache Tomcat as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0.116, 2.0.14, 1.3.7 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade org.apache.tomcat/tomcat to 9.0.116; org.apache.tomcat/tomcat-native to 2.0.14, 1.3.7, 1.2.40 or 1.1.35.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Tomcat | Affected
| Fixed in– |
| Apache Software FoundationApache Tomcat Native | Affected
| Fixed in– |
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in
|
Mavenorg.apache.tomcat/tomcat-nativepkg:maven/org.apache.tomcat/tomcat-nativeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrading to the fixed versions is recommended: Apache Tomcat 9.0.116, 10.1.53, or 11.0.20 and Apache Tomcat Native 1.3.7 or 2.0.14. These versions address the authentication failure issue. No other mitigation guidance is provided. Patch status is confirmed by the vendor advisory recommending these upgrades.
Description
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13. Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.