CVE-2026-29146: Apache Tomcat · Padding Oracle
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 9.0.116 : patch Apache Tomcat soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 8.8% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0.116, 8.5.101, 7.0.110
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade org.apache.tomcat/tomcat to 9.0.116, 8.5.101 or 7.0.110.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Tomcat | Affected
| Fixed in– |
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading Apache Tomcat to versions 11.0.19, 10.1.53, or 9.0.116 or later. Alternatively, mitigation can be applied by removing the affected catalina-tribes.jar file from the Tomcat installation, which disables clustering functionality. If clustering is required, ensure it is disabled before applying this mitigation to avoid service errors. Red Hat advises disabling clustering in their Tomcat distributions and applying the update as per their security advisory.
Description
Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.
References
- lists.apache.org/thread/lzt04z2pb3dc5tk85obn80xygw3z1p0w (opens in a new tab)
- openwall.com/lists/oss-security/2026/04/09/24 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-29146 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2457020 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-29146.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:20405 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:39188 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:38505 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36787 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36789 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36788 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36790 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37137 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37136 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36878 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36876 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36877 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36879 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:20406 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:39189 (opens in a new tab)