CVE-2026-29170: Apache HTTP Server · Cross-site Scripting
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium · fixed in 2.4.68 : update Apache HTTP Server when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
AI-suggested
Users should upgrade Apache HTTP Server to version 2.4.68 or later, where this vulnerability is fixed. No other mitigations are specified. Patch status is confirmed by the vendor recommendation to upgrade to 2.4.68.
Description
CVE-2026-29170 is a cross-site scripting (XSS) vulnerability in Apache HTTP Server's mod_proxy_ftp module affecting versions 2.4.67 and earlier. The issue occurs during HTML directory list generation when listing FTP directory contents via forward or reverse proxy. This vulnerability allows an attacker to inject malicious scripts that could be executed in the context of the user's browser. The Apache Software Foundation recommends upgrading to version 2.4.68 to address this vulnerability.