CVE-2026-29785: nats-server · NULL Pointer Dereference
Affects nats-serverSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.12.5 or 2.11.14 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.5, 2.11.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nats-server to 2.12.5 or 2.11.14; nats-io/nats-server to 2.11.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nats-ionats-server | Affected
| Fixed in
|
| nats-ionats-server | Affected
| Fixed in
|
GitHubnats-io/nats-serverpkg:github/nats-io/nats-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in nats-server versions 2.11.14 and 2.12.5. Users should upgrade to these or later versions to remediate the vulnerability. As a workaround, disabling compression on the leafnode port can prevent exploitation, though this may affect performance or functionality. The Red Hat advisory notes that no mitigation fully meets their criteria except upgrading. Users should consult the vendor advisory and apply the official fixes. No other mitigations are recommended.
Description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.14 and 2.12.5, if the nats-server has the "leafnode" configuration enabled (not default), then anyone who can connect can crash the nats-server by triggering a panic. This happens pre-authentication and requires that compression be enabled (which it is, by default, when leafnodes are used). Versions 2.11.14 and 2.12.5 contain a fix. As a workaround, disable compression on the leafnode port.
References
- github.com/nats-io/nats-server/security/advisories/GHSA-52jh-2xxh-pwh6 (opens in a new tab)
- github.com/nats-io/nats-server/commit/a1488de6f2ba6e666aef0f9cce0016f7f167d6a8 (opens in a new tab)
- advisories.nats.io/CVE/secnote-2026-04.txt (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-29785 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2451444 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-29785.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:22347 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:23345 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:21769 (opens in a new tab)