Skip to main content
VulnerabilityPublished Updated

CVE-2026-29971: WebFileSys · XSS

Affects WebFileSysSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.32.0 when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.32.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade tharooon/WebFileSys to 2.32.0.

Affected software

ProductAffectedFixed in
GitHubtharooon/WebFileSyspkg:github/tharooon/WebFileSysOther threatsAffected
  • <2.32.0
Fixed in
  • 2.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in WebFileSys version 2.32.0. Users and administrators should upgrade to this version to remediate the vulnerability. Since this is a reflected XSS, applying the official patch is the recommended mitigation. Patch status is not explicitly confirmed in vendor advisory content, but the description states the issue is fixed in 2.32.0. No other mitigation guidance is provided.

Description

CVE-2026-29971 is a reflected cross-site scripting (XSS) vulnerability in WebFileSys versions prior to 2.32.0. The flaw occurs because user input is improperly encoded before being reflected in HTML and JavaScript contexts. This affects multiple components including ftpBackup functionality, authentication input handling, search functionality, and error message rendering. The vulnerability allows an attacker to execute arbitrary JavaScript in the victim's browser. It has a CVSS score of 6.1, indicating medium severity. A fix was introduced in version 2.32.

References

Community reviews

Loading reviews…