Skip to main content
VulnerabilityPublished Updated

CVE-2026-3012: Red Hat Enterprise Linux 10 samba · Insufficient Verification of Data Authenticity

Affects Red Hat Enterprise Linux 10 sambaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.0 High : upgrade the Red Hat redhat/samba package to 10.2 or 8.10 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2, 8.10
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Red Hat redhat/samba package to 10.2 or 8.10.

Affected software

ProductAffectedFixed in
Red Hatredhat/sambapkg:rpm/redhat/sambaOther threatsAffected
  • >=8.0.0 <8.10
  • >=10.0.0 <10.2
Fixed in
  • 8.10
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates that fix this vulnerability. Users should apply the updated Samba packages provided in Red Hat Enterprise Linux 8.10 and 10.2 or later as described in Red Hat advisories RHSA-2026:22644 and RHSA-2026:22963. The vendor advisory confirms the availability of patches and recommends updating to these fixed versions to remediate the issue.

Description

A flaw was found in Samba’s certificate auto-enrollment Group Policy handling. When certificate auto-enrollment is enabled, Samba may retrieve a CA certificate over an unencrypted HTTP connection and install it into the local trust store without proper verification. An attacker with the ability to intercept or redirect network traffic could exploit this behavior to supply a malicious certificate authority certificate, potentially allowing interception or spoofing of trusted communications.

References

Community reviews

Loading reviews…