CVE-2026-30778: Apache SkyWalking · Exposure of Sensitive Information Through Data Queries
Affects Apache SkyWalkingSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 10.4.0 : patch Apache SkyWalking soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache SkyWalking | Affected
| Fixed in– |
Mavenorg.apache.skywalking/skywalkingpkg:maven/org.apache.skywalking/skywalkingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache SkyWalking to version 10.4.0, which contains the official fix for this vulnerability. Since this is a self-hosted product, applying the vendor-released update is the recommended remediation. Patch status is confirmed by the vendor advisory recommending upgrade to 10.4.0. No additional mitigations are specified.
Description
CVE-2026-30778 is a vulnerability in Apache SkyWalking versions 9.7.0 through 10.3.0 where the /debugging/config/dump endpoint may expose sensitive configuration information related to MySQL and PostgreSQL databases. This exposure can lead to unauthorized access to critical configuration data. The issue is resolved in Apache SkyWalking version 10.4.0, which users are advised to upgrade to. The vulnerability has a CVSS score of 7.