CVE-2026-30879: baserproject basercms · Cross-site Scripting
Affects baserproject basercmsSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 5.2.3 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.2.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade basercms and baserproject/basercms to 5.2.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| baserprojectbasercms | Affected
| Fixed in
|
GitHubbaserproject/basercmspkg:github/baserproject/basercmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade baserCMS to version 5.2.3 or later, where this cross-site scripting vulnerability has been patched. No other mitigation steps are indicated by the vendor advisory.
Description
baserCMS versions prior to 5.2.3 contain a cross-site scripting (XSS) vulnerability in blog posts due to improper neutralization of input during web page generation. This vulnerability has been addressed and patched in version 5.2.3. The CVSS 4.0 base score is 6.9, indicating a medium severity level. There are no known exploits in the wild at this time.