Skip to main content
VulnerabilityPublished Updated

CVE-2026-31417: Linux kernel · net/x25: Fix overflow when accumulating packets

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.5 High : upgrade to 7.0.0-1006.6 soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1006.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu linux-nvidia package to 7.0.0-1006.6.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia@7.0.0-1006.6?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.6
Fixed in
  • 7.0.0-1006.6
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threatsAffected
  • 6.14.0-15.15 – 6.17.0-40.40
20 affected builds
Fixed in–
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1019.19
17 affected builds
Fixed in–
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1020.22?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1006.6 – 6.17.0-1020.22
17 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions. The vendor advisory from Ubuntu confirms that this issue is fixed in updated kernel packages. Users should update their Linux kernel to the patched versions provided by their distribution to mitigate this vulnerability.

Description

A vulnerability in the Linux kernel's net/x25 subsystem related to an integer overflow when accumulating packets has been fixed. The issue involved the x25_sock.fraglen value potentially overflowing and not being reset properly when purging the fragment queue. This flaw could lead to a denial of service by causing an overflow condition. Multiple specific Linux kernel versions are affected. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…