Skip to main content
VulnerabilityPublished Updated

CVE-2026-31430: Linux kernel · X.509: Fix out-of-bounds access when parsing extensions

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.1 High : upgrade to 7.0.0-1006.6 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.08% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1006.6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu linux-nvidia package to 7.0.0-1006.6.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia@7.0.0-1006.6?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.6
Fixed in
  • 7.0.0-1006.6
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threatsAffected
  • 6.14.0-15.15 – 6.17.0-40.40
20 affected builds
Fixed in–
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1019.19
17 affected builds
Fixed in–
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1020.22?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1006.6 – 6.17.0-1020.22
17 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released by the vendor. Users should update their Linux kernel to version 6.8.0-1064.72~22.04.1 or later as provided in the Ubuntu security notices USN-8567-1 and USN-8574-1. After applying the update, a system reboot is required to activate the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. Follow the vendor's update instructions carefully.

Description

In the Linux kernel, the following vulnerability has been resolved: X.509: Fix out-of-bounds access when parsing extensions Leo reports an out-of-bounds access when parsing a certificate with empty Basic Constraints or Key Usage extension because the first byte of the extension is read before checking its length. Fix it. The bug can be triggered by an unprivileged user by submitting a specially crafted certificate to the kernel through the keyrings(7) API. Leo has demonstrated this with a proof-of-concept program responsibly disclosed off-list.

References

Community reviews

Loading reviews…