Skip to main content
VulnerabilityPublished Updated

CVE-2026-31436: Linux kernel · dmaengine: idxd: fix possible wrong descriptor completion in llist_abort_desc()

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-31436· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 6.8.0-1060.63~22.04.1 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1060.63~22.04.1, 6.8.0-1063.71~22.04.1, 6.8.0-1062.69~22.04.1 +45
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-40.40
Fixed in
  • 6.17.0-40.40
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1019.19
Fixed in
  • 6.17.0-1019.19
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1020.22
Fixed in
  • 6.17.0-1020.22
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1018.18
Fixed in
  • 6.17.0-1018.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and included in updated Linux kernel packages starting from version 6.8.0-1060.63~22.04.1 and later. Users should apply the official Ubuntu security updates (e.g., linux-image-6.17.0-40.40 and related packages) and reboot their systems to activate the fixes. Due to an ABI change, recompilation and reinstallation of all third-party kernel modules are required after updating. Follow the vendor's update instructions as detailed in Ubuntu Security Notices USN-8490-1 and USN-8491-1.

Description

A high-severity vulnerability (CVE-2026-31436) in the Linux kernel's dmaengine subsystem was fixed. The issue involved incorrect completion of descriptors in the idxd driver function llist_abort_desc(), which could cause NULL pointer dereferences, double completions, or descriptor leaks. This flaw was resolved by correcting the code to complete the correct descriptor. The vulnerability affects multiple Linux kernel versions prior to 6.8.0-1060.63~22.04.1 and similar builds. Ubuntu has released patches addressing this and other kernel security issues, requiring system updates and reboots. Due to ABI changes, recompilation of third-party kernel modules is necessary after updating. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…