CVE-2026-31600: Linux kernel · arm64: mm: Handle invalid large leaf mappings correctly
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 7.0.0-28.28~24.04.1 : patch Linux kernel soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-28.28~24.04.1, 7.0.0-27.27, 7.0.0-1008.8 +6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to Linux kernel versions 7.0.0-27.27 or later as provided by the vendor. Ubuntu has released security updates addressing this issue in multiple kernel packages. After applying the update, a system reboot is required. Due to ABI changes, third-party kernel modules must be recompiled and reinstalled. No additional mitigation actions are indicated by the vendor advisory.
Description
CVE-2026-31600 is a vulnerability in the Linux kernel's ARM64 memory management subsystem. It involves improper handling of invalid large leaf page table entries (PTEs), which can cause kernel panics during certain operations such as booting a realm guest on specific hardware configurations. The flaw arises because parts of the kernel code were not designed to handle invalid large leaf mappings correctly. This issue has been addressed in Linux kernel versions starting from 7.0.0-27.27 and related releases.
References
- ubuntu.com/security/CVE-2026-31600 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-31600 (opens in a new tab)
- git.kernel.org/linus/15bfba1ad77fad8e45a37aae54b3c813b33fe27c (opens in a new tab)
- ubuntu.com/security/notices/USN-8488-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8488-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8507-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8569-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)